Dynamic video generation is currently experiencing intermittent issues.
Resolved
Nov 18 at 05:12am MST
SOLVED - Dynamic video generation is currently experiencing intermittent issues.
Some of our providers are affected by an ongoing Cloudflare global outage, which is causing delays in generating new videos.
All other features are functioning normally. Previously generated videos remain fully shareable and playable for your prospects.
We’ll provide updates as the situation evolves.
Full Cloudflare updates: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
History:
Resolved (Cloudflare) - This incident has been resolved.
Posted Nov 18, 2025 - 19:28 UTC
Update (Cloudflare) - Cloudflare services are currently operating normally. We are no longer observing elevated errors or latency across the network.
Our engineering teams continue to closely monitor the platform and perform a deeper investigation into the earlier disruption, but no configuration changes are being made at this time.
At this point, it is considered safe to re-enable any Cloudflare services that were temporarily disabled during the incident. We will provide a final update once our investigation is complete.
Posted 3 hours ago. Nov 18, 2025 - 17:44 UTC
Important Cloudflare Updates
Update (Cloudflare) - We continue to monitor the system through recovery and we are seeing errors and latency return to normal levels. A full post-incident investigation and details about the incident will be made available asap.
Nov 18, 2025 - 17:14 UTC
Update (Cloudflare) - A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Nov 18, 2025 - 14:42 UTC
Update (Cloudflare) - We've deployed a change which has restored dashboard services. We are still working to remediate broad application services impact
Nov 18, 2025 - 14:34 UTC
Affected services