Incident: Service Degradation on Real-Time Notifications & Authentication caused By Providers
Resolved
Oct 20 at 08:26am MST
Resolved - This incident has been resolved.
Oct 21, 2025 - 02:40 UTC
Update - Our Auth provider solved the sign-in, sign-up, log-out and any affected services on their end
Oct 21, 2025 - 02:31 UTC
Update - Real-time notification looks working as normal, but we should keep an eye on it because our web-socket provider status still as service degraded.
Oct 20, 2025 - 05:13 UTC
Update - Auth provider have finished deploying across all affected services and services have been restored. We will continue to monitor to ensure no additional impact.
Oct 21, 2025 - 01:51 UTC
Update - Auth provider have begun rolling out fixes across services, and will be verifying recovery as it deploys.
Oct 21, 2025 - 00:54 UTC
Update - Auth provider have identified the issue and are working on a fix. We'll update again when we've rolled it out.
Oct 20, 2025 - 23:41 UTC
Update - Auth provider issue research in progress.
Oct 20, 2025 - 22:15 UTC
Update - Our Auth provider still having issue with a third-party provider affecting sign-in, sign-up and log-out services.
Oct 20, 2025 - 21:20 UTC
Update - AWS service was not affected our Auth provider anymore, but there are some third-party providers affecting our Auth provider.
Oct 20, 2025 - 20:12 UTC
Update - Ongoing Service Outage Due to AWS Provider Issues
Oct 20, 2025 - 20:12 UTC
Identified – A service degradation incident on AWS infrastructure impacted several of our third-party providers and their upstream services, resulting in a cascading service disruption around the world.
Oct 20, 2025 - 19:15 UTC
Monitoring – We are currently experiencing a service degradation due to issues with third-party Push Notification and Authentication providers.
Oct 20, 2025 - 18:20 UTC
Impacted Services:
Real-time notifications
- Prospect status updates may not reflect in real time.
- “Video Ready” notifications in the Chrome Extension, App Recorder and Desktop App may be delayed or missing.
Authentication
- Users may experience intermittent issues or delays when signing in, signing up, or logging out.
Workarounds:
- Prospect Status: Refresh the Prospect Table to view the latest progress.
- Video Ready Notifications: Use the Desktop App or in App Recorder instead and check My Library (or folder where was recorded the video) to confirm video availability.
- DO NOT use CE: Use *Desktop App or in App Recorder instead to avoid lost your videos during this issue.
- Video Ready Notifications: Download video just in case
We are working closely with our providers to resolve the issue and will update this page as more information becomes available.
Start time: Oct 20, 2025 - 17:26 UTC
Current status: Monitoring
Next update: As soon as more information is available
Affected services