Widespread Cloud Provider Outage Impacting Sendspark Availability
Resolved
Jun 12 at 11:41am MST
Status
Service is fully operational
Identified:
The issue has been identified as a widespread outage affecting multiple cloud service providers. Google Cloud Platform (GCP)
Thank you for your continued patience.
Monitoring 3:14 pm CT
Cloud Provider implemented mitigation for the issue in us-central1 and multi-region/us and we are seeing signs of recovery
Incident History:
06/12/2025 5:01 pm CT
Sendspark is fully operational! ✅ 🚀
Our cloud providers are showing signs of recovery based on internal monitoring and customer feedback. Thank you for your patience, let’s get back to recording videos! 🚀.
06/12/2025 3:14 pm CT
Cloud Provider Update:
We have implemented mitigation for the issue in us-central1 and multi-region/us and we are seeing signs of recovery.
We have received confirmation from our internal monitoring and customers that the Google Cloud products are also seeing recovery in multiple regions and are also seeing signs of some recovery in us-central1 and mutli-region/us.
We expect the recovery to complete in less than an hour.
We will provide an update by Thursday, 2025-06-12 4:30 CT with current details.
06/12/2025 2:14 pm CT
The issue has been identified as a widespread outage affecting multiple cloud service providers. Google Cloud Platform (GCP), GitHub, ElevenLabs, and HubSpot have acknowledged incidents on their respective platforms. This is impacting Sendspark’s ability to serve video content and process some requests.
https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
https://www.githubstatus.com/incidents/d9xd9k1j6sl0
https://status.hubspot.com/incidents/0fd3q8bd9bss
06/12/2025 11:41 am CT
Sendspark is currently experiencing service disruptions beginning around 12:30 PM CT due to an upstream outage with major cloud providers. The issue appears to be part of a larger widespread cloud incident affecting multiple services including AWS, Google Cloud Platform (GCP), Cloudflare, Discord, Twitch, Mailchimp, and others. check this link for more details about companies with these issues: https://downdetector.com/
Our engineering team is actively monitoring the situation and working on implementing mitigations where possible while awaiting further updates from our infrastructure providers.
We will continue to post updates as more information becomes available.
Affected services
API v2
Share Page
Thumbnails API
Analytics API